summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 8714012..dbdfe88 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -10,6 +10,47 @@ Flask = "1.1.2"
beautifulsoup4 = "4.9.3"
[tool.poetry.group.dev.dependencies]
+ruff = "0.4.2"
+
+[tool.ruff]
+line-length = 120
+
+target-version = "py39" # wgmd.de server version
+
+lint.select = [
+ # Pyflakes
+ "F",
+ # Pycodestyle
+ "E",
+ "W",
+ # flake8-bugbear
+ "B",
+ "C",
+ # flake8-comprehensions
+ "C4",
+ # flake8-implicit-str-concat
+ "ISC",
+ # isort
+ "I",
+ # mccabe (complexity)
+ "C901",
+ # pyupgrade / python features for selected version
+ "UP",
+ # flake8-pytest-style
+ "PT",
+ # flake8-simplify
+ "SIM",
+ # flake8-print
+ "T20",
+ # pylint
+ "PLC", "PLE", "PLR", "PLW",
+ # Ruff specific
+ "RUF",
+]
+
+lint.ignore = [
+ "ISC001", # causes issues with formatter
+]
[build-system]
requires = ["poetry-core>=1.7.0"]